Jump to content
The Motorists' Guide

About This Club

Have a problem with your car? Need to know how to maintain your car? Ask your question here and we'll see if we can help!
  1. What's new in this club
  2. Engine Oils and Fluids (click link below for offer) 25% off engine oils & fluidsTime to top up. Ends 14 Oct, 10am Car cleaning products (click link below for offer) 20% off car care & cleaning.  Save on kits & products. Ends 14 Oct, 10am.
  3. Register now as a Member to post in the forums (FREE Basic Membership) Click here to Register for FREE
  4. Register now as a Member to post in the forums (FREE Basic Membership) Click here to Register for FREE
  5. Welcome to the Classic Car section of these forums! Older cars generally require more attention than modern vehicles but the operational principles remain the same Feel free to post you classic car issues in here and we will endeavour to offer the advice you need to get your car back up and running in perfect order
  6. Hi autoevoke Thanks so much for that I had my partner top up the fluid and the problem has not recurred since, so fingers crossed this has been a simple and cheap cure.
  7. Hi Alfa4 I have come across the problem before and you'll be pleased to know it is a very simple and cheap fix! The brake fluid will need topping (maybe just very slightly) as the chassis control system senses the level is too low. First time I experienced this I was surprised at how simple yet also how complex the system is to take the fluid level reading this precisely. Top up the fluid to the 'maximum' level but no higher and see if the light extinguishes and does not return. Also, consider that the fluid level may have dropped for a reason! This could be a major problem with a hydraulic component if the level has dropped a significant amount but if only dropped slightly then it is more than likely the brake pads may have worn low. Either way, have the brake components inspected for safety and condition
  8. I own a 2012 Nissan Juke 1.6 petrol and i have noticed the traction control light and ABS light come on intermittantly when driving. It happens periodically and does not follow any particular pattern. Everything seems fine with the car and it drives fine its just the light that comes on Also it has a strange "twanging noise" when the light comes on. Please can you give me some idea of what is going wrong and will it be expensive Thanks in advance for any help you can offer 🙂
  9.  


×
×
  • Create New...